AudioValve`s FAQ Center …

go back to the AudioValve „HOME – main“ site this way …


select your language here to read all posts, to post you must log in or create an account. Register here and post or find answers and questions to your products from AudioValve. We have this forum on a different server, for this reason it is much more faster, more effective and more comfortable for us to edit than would be possible on our main page. Unfortunately, all browsers do not allow the loading of content from another server, for this reason the forum can only be viewed via a new tab. But I think we can live with that …

Bitte oder Registrieren, um Beiträge und Themen zu erstellen.

older Challenger model in repair

Hello Herr Becker,

The PWB picture is below. 

Yes, we had a nice chat once with the ELectrical Engineer I recruited to keep the Challenger working. He is a Senior Fellow EE- a quite distinguished guy - who used to work at Texas Instruments where he knew Mr K. and Mr M.. He repairs guitar amps for local musicians at reasonable cost just as a pastime. Lucky for me he said, “I never saw an amp I couldn’t repair” when I first contacted him about my dead Challenger. Also lucky  for me he considered the Challenger’s innovative design a challenge and figured it out. Your proprietary bias circuit that was not on the schematic was the problem. He had to reverse engineer that to repair it that first time but he now has the schematics to keep it alive. So now, lucky for me, the amps are sustainable.  And don’t worry,  neither of us will share any information whatsoever with anyone about your design. We were both in the electronics business for many year’s and understand the importance of proprietary information to a business. 

But we noticed during this trip to his workshop that the mains fuse was 16 amps and the plate fuses varied from a couple 400 ma fuses to  1 amp to 4 amps from prior owners!  Thus my question about the proper fuses. We did run the amp at 135 watts steady state with the 400ma fuses and they do appear to work fine. 

Obviously I love the sound of your amplifier in my system or I wouldn’t keep fussing with it. I suppose bad tubes, age and prior owners have taken their toll it’s reliability. But I have a path to keep working so I’ll continue to enjoy it. Maybe with good tubes it will run happily many hours. 

Thank you for designing and producing such an excellent sounding product. 

Bill F.   Sent from my iPhone

ANSWER

Hello Bill, I'm glad to hear that things are running again for now. Yes, I'm not a friend of these big things like e.g. KT88 they are not really stable in all areas and then they also tend to thermal collapse, which sometimes also to thermal collapse, so I would turn them off again and instead I would use EL34 with the sino browbone, the are very stable and generate real pressure with up to 150 watts per channel.

I would choose the primary mains fuse up to a maximum of 6 to 8 amps for 115 VAC from the wall and the fuses to the output tubes with 600 milliamperes are slow blow. There are 2 pcs. 47/100 volt electrolytic capacitors in front of each power tube on the left and right, the minus side to the front you should perhaps change them if they are too old, just pinch them out from above and put new ones on the soldering pads. If these electrolytic capacitors draw leakage currents, it can distort the bias current and become too high, that's it.

stay safe and best regards, Helmut

 

Hochgeladene Dateien:
  • chall-1990.jpg

I am pretty sure that I have the same amplifier (mine are the Challenger 160 Millennium Edition).  Is there a schematic available for it?  I'm wondering if it can be converted from 117v to 220v.